Проверка кпп

Узнать код КПП по ИНН организации

Проверка кпп

КПП по ИНН узнать довольно просто. Специальные сервисы по проверке контрагентов и официальные ресурсы помогут вам сделать это быстро и в почти всегда бесплатно. Расскажем о способах поиска основных реквизитов в сети интернет.

КПП — код причины постановки на учёт. Организации получают эту комбинацию цифр, которая дополняет ИНН, при регистрации.

Невозможно узнать по ИНН КПП ИП, поскольку индивидуальным предпринимателям этот код не присваивается.

Комбинация состоит из 9 знаков и расшифровывается так:

  • Первые 2 цифры — код региона, где зарегистрирована компания. У крупнейших налогоплательщиков, которые зарегистрированы в межрегиональных инспекциях КПП начинается с цифр «99». Это дополнительно присвоенный реквизит, который указывают при уплате федеральных налогов; региональный код у таких компаний тоже сохраняется. Поэтому у крупнейших налогоплательщиков два присвоенных кода, которые используются в разных случаях.
  • 3-я и 4-я цифры — номер налоговой инспекции, поставившей на учёт фирму. Вместе 4 первые цифры составляют код ИФНС, к которой прикреплена компания.
  • 5-й и 6-й знак — зашифрованная причина постановки на учёт;
  • Последние 3 цифры — порядковый номер при постановке на учёт.

Обособленные подразделения — филиалы и представительства — не регистрируются как отдельные юридические лица. Юридическое лицо одно, а подразделения считаются его частью, имея одинаковый с главным предприятием ИНН. Несмотря на один и тот же идентификационный номер, код постановки на учет филиала или представительства может отличаться от кода основного юрлица.

Код обособленного подразделения привязан к той ИФНС, где зарегистрирован сам филиал.

Проверить КПП обособленного подразделения онлайн сложно — в официальных выписках из ЕГРЮЛ не содержится такая подробная информация о филиалах и представительствах компаний. Если вам необходимо узнать именно код подразделения, лучше обратиться за реквизитами в сам филиал или использовать коммерческие версии программ.

Как узнать КПП по ИНН — подробная инструкция

Разберёмся, как узнать КПП по ИНН организации при помощи сервисов по проверке контрагентов и запишем этот процесс в виде инструкции. При использовании одной из представленных ниже программ вы сможете узнать нужный реквизит в 2-3 шага.

Как определить КПП по ИНН организации при помощи сервиса Контур Фокус

1. ИНН вбивается в поисковую строку на сайте проверки контрагента Контур.Фокус — для поиска войдите в платный аккаунт или откройте бесплатный демодоступ на время. После нажатия на кнопку поиска станет доступна информация об организации.

2. Основные реквизиты видны сразу под названием компании.

Как узнать КПП по ИНН организации при помощи сервиса Fira Pro

1. Полную справку, которая помогает оценить риски и преимущества сотрудничества с компанией, сервис предоставляет платно. Однако код причины постановки на учёт виден без регистрации и перевода денег. Просто перейдите по ссылке на страницу сайта, введите идентификационный номер налогоплательщика в строку и нажмите кнопку поиска, чтобы узнать нужную информацию.

2. Вы попадёте в карточку компании: чтобы узнать нужные данные выберите в меню слева «Основные сведения», затем «Реквизиты».

3. Среди реквизитов откроются три вкладки:

  • данные ФНС,
  • данные Росстата;
  • сравнительные данные, которые доступны только в платной версии.

Нужную информацию о компании вы найдёте во вкладке — данные ФНС.

Как узнать КПП по ИНН организации при помощи сервиса СКРИН@АСТРАЛ

1. У сервиса СКРИН@АСТРАЛ нет бесплатной демоверсии, поиском в этой системе могут воспользоваться коммерческие пользователи. После входа в систему под своим логином нажмите вкладку «Юридические лица». В первую строку поиска впишите идентификационный номер налогоплательщика или название организации и нажмите «Найти».

2. Из списка открывшихся подразделений Сбербанка выберите первый пункт — головное предприятие.

3. На странице появятся основные сведения об организации.

Как узнать код постановки на учёт по ИНН организации при помощи сервиса Unirate24

1. Реквизиты организации видны в выписке из ЕГРЮЛ, которую можно купить на сайте Unirate24 за 100 рублей. Пополните баланс с помощью банковской карты или счёта, выберите вид справки и нажмите «Далее». Более дорогая бизнес-справка, помимо основной информации, содержит анализ финансовой деятельности компании.

2. Нужный нам реквизит в выписке во второй колонке.

Как узнать КПП по ИНН организации на сайте налоговой службы

1. На странице поиска сведений о регистрации юридических лиц введите известный реквизит и цифры с картинки, затем нажмите «Найти».

2. Чтобы найти КПП организации на сайте налоговой, не придётся скачивать выписку из ЕГРЮЛ — реквизит виден сразу на открывшейся странице.

Источник: https://ppt.ru/inn/kpp

Алгоритм проверки уникальности и корректности ИНН, КПП при записи контрагента для БП 1.6 и 2.0 через подписку на события

Проверка кпп

В УПП есть типовой механизм проверки контрагента на уникальность при записи.В БП 2.0 такой типовой проверки нет, пришлось добавлять свою, к тому же логика УПП-шной проверки меня не совсем устраивает. Предлагаю свой вариант алгоритма проверки ИНН и КПП при записи элемента справочника Контрагенты.

Ни на что не претендую, если инфа будет кому-то полезна, значит не зря потратил время :).К тому же этот вопрос возникает с неизменной периодичностью на всех форумах. Реализовано с помощью подписки на событие, что позволяет спокойно обновлять конфигурацию.

Приведенный ниже код проверяет корректность в ИНН и КПП на:    – длина    – недопустимые символы    – уникальность ИНН+КПП (для юрлица) или уникальность ИНН (для физлица)     – проверка корректности ИНН на контрольный разряд P.S. это первая публикация, сильно не ругайте, если есть замечания – сообщите

обновлено 13.03.

2012 : добавлена проверка на Отказ, ОбменДанными.Загрузка,  ЭтоГруппа (спасибо http://forum.infostart.ru/forum24/topic51955/message616590/#message616590)

В конфигурации БП реализовал следующим образом:

1) создал подписку на событие

Источник: СправочникОбъект.Контрагенты

Событие: ПередЗаписью

Обработчик: МойОбщийМодуль.ПередЗаписьюКонтрагента (где МойОбщийМодуль – собственный общий модуль, но можно при желании можно и в один из типовых засунуть)

2) собственно сам обработчик

//добавлено – 11/05/2010 (проверка на корректность и уникальность ИНН и КПП)
Процедура ПередЗаписьюКонтрагента(Источник, Отказ) Экспорт

    Если Отказ ИЛИ Источник.ОбменДанными.Загрузка ИЛИ Источник.ЭтоГруппа Тогда

        Возврат;    КонецЕсли;

    Если

Источник.ЮрФизЛицо = Перечисления.ЮрФизЛицо.ФизЛицо Тогда
        ЭтоФизлицо ЭтоФизлицо // проверка ИНН на заполнение
    ИНН = Источник.ИНН;
    Если СтрДлина(ИНН) ?(ЭтоФизлицо, 12, 10) Тогда
        СообщениеОНевозможностиЗаписи = “Неверное количество символов в реквизите ИНН!!!” + Символы.

ПС
            + “Текущее количество символов: ” + СтрДлина(ИНН) + Символы.ПС
            + “Требуемое количество символов для ” + ?(ЭтоФизлицо, “Физлица: 12″,”Юрлица: 10”);
        ОбщегоНазначения.

СообщитьОбОшибке(СообщениеОНевозможностиЗаписи);
        Отказ = Истина;        Возврат;    КонецЕсли;// проверка ИНН на недопустимые символы
    Результат = Истина;
    Для а = 1 По СтрДлина(ИНН) Цикл
        Если Найти(“0123456789”, Сред(ИНН,а,1)) = 0 Тогда
            НекорректныйСимвол = Сред(ИНН,а,1);
            Результат = Ложь;            Прервать;        КонецЕсли;    КонецЦикла;

    Если НЕ

Результат Тогда
        СообщениеОНевозможностиЗаписи = “Недопустимый символ в реквизите ИНН: !!!”;
        ОбщегоНазначения.СообщитьОбОшибке(СообщениеОНевозможностиЗаписи);
        Отказ = Истина;        Возврат;    КонецЕсли;// проверка ИНН на контрольный разряд

    Если НЕ РегламентированнаяОтчетность.ИННСоответствуетТребованиям(ИНН, ЮрФизЛицо) Тогда
        СообщениеОНевозможностиЗаписи = “ИНН задан неверно (не прошел проверку на контрольный разряд)!!!”;
        ОбщегоНазначения.

СообщитьОбОшибке(СообщениеОНевозможностиЗаписи);
        Отказ     КонецЕсли;

    Если НЕ ЭтоФизлицо Тогда
    // проверка КПП на заполнение
        КПП = Источник.

КПП;
        Если СтрДлина(КПП) 9 Тогда
            СообщениеОНевозможностиЗаписи = “Неверное количество символов в реквизите КПП!!!” + Символы.ПС
            + “Текущее количество символов: ” + СтрДлина(КПП) + Символы.

ПС
            + “Требуемое количество символов: 9”;
            ОбщегоНазначения.

СообщитьОбОшибке(СообщениеОНевозможностиЗаписи);
            Отказ = Истина;            Возврат;        КонецЕсли;// проверка КПП на недопустимые символы
        Результат = Истина;
        Для а = 1 По СтрДлина(КПП) Цикл
            Если Найти(“0123456789”, Сред(КПП,а,1)) = 0 Тогда
                НекорректныйСимвол = Сред(КПП,а,1);
                Результат = Ложь;                Прервать;            КонецЕсли;        КонецЦикла;

        Если НЕ

Результат Тогда
            СообщениеОНевозможностиЗаписи = “Недопустимый символ в реквизите КПП: !!!”;
            ОбщегоНазначения.

СообщитьОбОшибке(СообщениеОНевозможностиЗаписи);
            Отказ = Истина;            Возврат;        КонецЕсли;    КонецЕсли;// поиск дубликатов в справочнике
    Запрос = Новый Запрос();
    Запрос.УстановитьПараметр(“ТекущийИНН”, ИНН);
    Запрос.

УстановитьПараметр(“ТекущийКПП”, КПП);
    Запрос.УстановитьПараметр(“Ссылка”, Источник.СсылкаЗапрос.Текст = “ВЫБРАТЬ РАЗРЕШЕННЫЕ ПЕРВЫЕ 1    |    Контрагенты.Ссылка,    |    ПРЕДСТАВЛЕНИЕ(Контрагенты.Ссылка) КАК ПредставлениеКонтрагента    |ИЗ    |    Справочник.

Контрагенты КАК Контрагенты    |ГДЕ    |    НЕ Контрагенты.Ссылка = &Ссылка    |    И Контрагенты.ИНН = &ТекущийИНН

    |   “

+ ?(ЭтоФизлицо, “”, ” И Контрагенты.КПП = &ТекущийКПП”ВыборкаКонтрагентов = Запрос.Выполнить().ВыбратьВыборкаКонтрагентов.Количество() 0 Тогда
        ВыборкаКонтрагентов.Следующий();
        СообщениеОНевозможностиЗаписи = “Уже существует контрагент с таким ИНН” + ?(ЭтоФизлицо, “”, ” И КПП”) + ” (” + ВыборкаКонтрагентов.Ссылка.Код + ” ” + ВыборкаКонтрагентов.ПредставлениеКонтрагента + “) !!!” ;
        ОбщегоНазначения.СообщитьОбОшибке(СообщениеОНевозможностиЗаписи);
        Отказ = Истина;        Возврат;    КонецЕсли;КонецПроцедуры//финиш – 11/05/2010 (проверка на корректность и уникальность ИНН и КПП)

Источник: https://infostart.ru/1c/articles/106129/

Поделиться:
Нет комментариев

    Добавить комментарий

    Ваш e-mail не будет опубликован. Все поля обязательны для заполнения.